问题解决:dyld: Library not loaded: /System/Library/Frameworks/Ruby.framework/Versions

系统升级到MacOS Catalina 10.15后,MacVim无法使用,报错如下:

dyld: Library not loaded: /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/libruby.2.3.0.dylib
  Referenced from: /usr/local/Cellar/macvim/8.1-153/MacVim.app/Contents/bin/../MacOS/Vim
  Reason: image not found

解决:
法一:通过brew更新MacVim:brew upgrade macvim
法二:重新安装mac vim:brew unlink macvim 然后 brew install macvim --HEAD


由于网络原因,我在更新过程中遇到brew报错:

Error: Another active Homebrew update process is already in progress.
Please wait for it to finish or terminate it to continue.

解决办法:rm -rf /usr/local/var/homebrew/locks

参考:
MacVim from brew crashes in MacOS Catalina 10.15

Another active Homebrew process is already in progress - Stack Overflow

相关推荐
©️2020 CSDN 皮肤主题: 撸撸猫 设计师:马嘣嘣 返回首页